Slowdown
Incident Report for zyBooks
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 07:44 PDT
Investigating
We are currently investigating this issue.
Posted Apr 22, 2024 - 07:20 PDT
This incident affected: learn.zybooks.com - zyBooks content and platform.