Reporting slowdown

Incident Report for zyBooks

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 13:09 PDT

Investigating

We are currently investigating an issue where some reports are slowing down including table of contents reports, assignments tab, student behavior insights, and zyLab similarity detection.
Posted Mar 24, 2025 - 12:00 PDT
This incident affected: learn.zybooks.com - zyBooks content and platform.